Статьи по 1С

Предложить тему

Основные параметры (ключи) запуска 1С

Основа Создаем bat файл (обычный текстовый файл у которого расширение bat) или указываем в настройках ИБ. Выбираем режим запуска 1с (для запуска через bat файл или cmd): 1. Запуск в режиме “1С:Предприятие”: «C:\Program Files (x86)\1cv82\8.2.14.519\bin\1cv8.exe» ENTERPRISE /F D:\ИБКурсы 2. Запуск

Поиск элементов справочника по наименованию

В данном случае рассмотрим поиск по наименованию.
Синтаксис:
Справочники.<НазваниеСправочника>.НайтиПоНаименованию (<Значение>, <ПоискПоПолномуСоответсвию>, <Родитель>, <Владелец>)

Поиск элементов справочника по произвольному реквизиту

В данном случае рассмотрим поиск по реквизиту. Реквизит может браться любой кроме реквизитов с неограниченной длиной и типом ХранилещеЗначений.
Синтаксис:
Справочники.<НазваниеСправочника>.НайтиПоРеквизиту (<ИмяРекизита>, <Значение>, <Родитель>, <Владелец>)

Поиск элементов справочника по коду

В данном случае рассмотрим поиск по коду. Можно использовать когда необходимо получить предопределенный элемент.
Синтаксис:
Справочники.<НазваниеСправочника>.НайтиПоКоду(<Код>, <ПоискПоПолномуКоду>, <Родитель>, <Владелец>)

Склонение фамилии, имени и отчества по падежам в 1С 8.2

Версия для 8.1 Исходный код: &НаКлиенте Процедура Команда1(Команда) ФИО = «Иванов Иван Иванович»; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры &НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) Результат = «»; ПутьКФайлу=»C:\NAMEDECL.DLL»; NameDecl = «Склонение»; Попытка Если

Месяц – получение месяца из даты [Функция 1С]

Определяет месяца в указанной дате. Синтаксис Месяц (<Дата>) Параметры Дата — дата Возвращаемое значение: месяц. тип число Прочее Доступность (для версии 8.2):Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение. Пример ТекДата = Дата(2012,06,27,07,30,60); Результат = Месяц (ТекДата); //Результат = 6

Год – получение года из даты [Функция 1С]

получение года из даты. Возвращается 4-х значное значение и если вам необходимо убрать разделитель (2 012), необходимо использовать Формат(Год(),»ЧГ=0″)Доступно в: Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение. Синтаксис Год (<Дата>) Дата — дата Результат: год из указанной даты, с

Секунда – получение секунды из даты [Функция 1С]

Позволяет получить секунды из даты. Синтаксис Секунда (<Дата>) Параметры Дата — дата Возвращаемое значение: Секунды из указанной даты, с типом число Прочее Доступность (для версии 8.2):Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение. Пример ТекДата = Дата(2012,06,27,07,30,50); Результат = Секунда

Минута – получение минуты из даты [Функция 1С]

получение минуты из даты Синтаксис Минута (<Дата>) Параметры Дата — дата Возвращаемое значение: Минута из исходной даты, с типом число Прочее Доступность (для версии 8.2):Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение. Пример ТекДата = Дата(2012,06,27,07,30,60); Результат = Минута (ТекДата);

Расположение регистра «Счета переоцениваемые в особом порядке».

Данный регистр имеет синоним «Счета с особым порядком переоценки», возможно это и является главной проблемой его поиска. Описание: В данном регистре сведений хранятся сведения о счетах бухгалтерского учета, на которых предусмотрено ведение валютного учета, но которые по тем или иным причинам не

Снятие с поддержки конфигурации для внесения изменений

Если у вас конфигурация находится на поддержке и не позволяет ее изменять (рис. 1), но вам необходимое изменить или добавить объект. Тогда открываем окно настройки поддержки, находится в главном меню «Конфигурация-Поддержка-Настройка поддержки». Внимание!! Cделайте копию ИБ или выгрузите ее (описание процесса выгрузки), иначе ваши изменения

Процедура сохранения табличного документа в файл excel

Для удобства использования я создам процедуру в общем глобальном модуле. Для ее вызова нам необходимо знать только название табличного документа, т.е. имя элемета. Процедура имеет 3 параметра: ИмяФайла — строка, содержит имя файла. Имя можно поменять в окне сохранения. ОткрытьФайл

Функция получения пути к рабочему столу

Данная функция может понадобится при открытии окна сохранения документа в файл. Для удобства я создал глобальный общий модуль выполняемый на клиенте и вставил в него функцию. Описание Объявим функцию: Функция ПутьКРабочемуСтолу() Экспорт Попытаемся получить адрес через Shell App = Новый COMОбъект(«Shell.Application»);

Импорт и заполнение табличного поля (таблицы значений) из файла Excel

Диалог выбора файла Выберем режим для диалога выбора файла, в данном случае это открытие: Режим = РежимДиалогаВыбораФайла.Открытие; Создадим сам диалог выбора: ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим); Выберем имя для файла, пригодится если файл имеет точное имя но может находится в разных

Заполнение табличного документа из запроса. Заполнение подвала и шапки таблицы.

Скачать выгрузку данной ИБ. Создадим процедуру в обработке НоваяОбработка, с именем ПолучитьДанные выполняемая на Сервере. &НаКлиенте Процедура Команда1(Команда) ПолучитьДанные(); КонецПроцедуры &НаСервере Процедура ПолучитьДанные() КонецПроцедуры Установим курсор внутри процедуры ПолучитьДанные. Запустим Конструктор запроса с обработкой результата (рис.1). Я буду использовать справочник Курсы, т.к.