Статьи по 1С

Предложить тему

Замена необходимых символов в строке на указанные

Данная функция позволяет найти в исходной строке значение и заменить на другое значение.При разработки конфигураций, часто требуется заменять какие либо символы в строке, по крайне мере я ей часто пользовался для упрощения работы. С данной задачей великолепно справляется функция СтрЗаменить.СинтаксисСтрЗаменить

Проверка на пустоту тип Дата

Если ПроверяемаяДата = Дата(1, 1, 1) Тогда Сообщить(«Дата пустая»); КонецЕсли; Вместо “Дата(1, 1, 1)” можно использовать следующие варианты: ‘00010101’ Дата(«00010101″) ‘00010101000000’ ‘0001-01-01′ Так же, можно использовать ЗначениеЗаполнено; Если НЕ ЗначениеЗаполнено(Объект.ПеременнаяДата) тогда     сообщить(«Строка пустая»); КонецЕсли;   В запросах 1. Дата

Склонение фамилии, имени и отчества по падежам в 1С 8.1

Версия склонения ФИО для 1C 8.2 Синтаксис Просклонять (<ФИО>, <Падеж>, <Пол>) Параметры <ФИО> – обязательный – строка содержащая фамилию, имя и отчество в именительном падеже единственного числа. Допустимые сочетания фамилии, имени и отчества: ФИО, ИОФ, ИО, ИФ, ФИ, Ф, И, О. Для

Проверка строки на пустоту

1 способ используя универсальную функцию ЗначениеЗаполнено(<исходная строка>) // если строка пустая или содержит только пробелы // тогда условие выполнится Строка = » «; Если НЕ ЗначениеЗаполнено(Строка) тогда сообщить("Строка пустая"); КонецЕсли; 2 способ сравнив значение с пустым значением (”“) // условие

Функции для работы с регистром строки

НРег – преобразование символов строки в нижний регистр Синтаксис НРег (<Исходная строка>) Параметры <Исходная строка> – исходная строка. Описание Преобразует все символы строки в нижний регистр. Доступность (для версии 8.2) Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение. Пример //

Проверка на пустоту типа хранилище значений

Функция для проверки “Хранилище значений” на пустоту: Функция ОпределитьЗаполненостьХранилища(Хранилище) Экспорт Если Хранилище.Получить() = Неопределено Тогда Возврат Ложь; Иначе Возврат Истина; КонецЕсли; КонецФункции Второй способ Хранилище.Получить() = Неопределено

Завершение работы пользователей

Нужно создать ярлыки (средствами windows) с командами или запускать через cmd: Для Файлового варианта Отключение пользователей: «C:\Program Files\1cv81\bin\1cv8.exe» ENTERPRISE /F <путь к базе> /N <имя> /P <пароль> /WA- /AU- /DisableStartupMessages /C ЗавершитьРаботуПользователей При этом произойдет запуск программы под админскими правами

Предложить статью

Если вы не нашли требуемую статью и не смогли решить свою задачу, вы можете оставить здесь воспользовавшись соответствующий формой, которая находится ниже. Вы можете прислать задачи которые просите решить программистов или сами решаете.