1С 8.1

Предложить тему

1С: Предприятие 8.1. Не добавляется сетевая информационная база.

Письмо на почте: Приветствую! Прошу оказать посильную помощь ))) Есть 1С 8.1 которую поставили всё как надо ... НО ... но ... при добавлении базы она не дает выбрать существующий сервер http://manual1c.ru/images/books/platforma82/admin/1236/5.jpg как у Вас указано ... Знатоки ВНИМАНИЕ ВОПРОС!...

Склонение фамилии, имени и отчества по падежам в 1С 8.2

Версия для 8.1 Исходный код: &НаКлиенте Процедура Команда1(Команда) ФИО = «Иванов Иван Иванович»; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры &НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) Результат = «»; ПутьКФайлу=»C:\NAMEDECL.DLL»; NameDecl = «Склонение»; Попытка Если

Процедура сохранения табличного документа в файл excel

Для удобства использования я создам процедуру в общем глобальном модуле. Для ее вызова нам необходимо знать только название табличного документа, т.е. имя элемета. Процедура имеет 3 параметра: ИмяФайла — строка, содержит имя файла. Имя можно поменять в окне сохранения. ОткрытьФайл

Преобразовании числа в строку и обратно

Преобразовании числа в строку Число = 2003; Строка = Строка(Число); //Строка = «2 003″, длина строки — 5 символов, включая неразрывный пробел //Чтобы преобразовать число к строке без вставки //символа-разделителя групп (неразрывного пробела), //нужно применить функцию Формат с параметром ЧГ=0:

Создание колонок в таблице значений

1. Создание колонок в новой таблице значений ТабЗначений = Новый ТаблицаЗначений; ТабЗначений .Колонки.Добавить("НомерСтроки", Новый ОписаниеТипов(«Число»)); ТабЗначений .Колонки.Добавить(«Сотрудник», Новый ОписаниеТипов(«СправочникСсылка.СотрудникиОрганизаций»)); ТабЗначений .Колонки.Добавить(«ДатаНачала», Новый ОписаниеТипов(«Дата»)); 2. Создание колонок в существующей ТабПоле.Колонки.Добавить(«ИмяКолонки», Новый ОписаниеТипов(«Строка»), «ЗаголовокКолонки»); ЭлементыФормы.ТабПоле.Значение = ТабПоле; ЭлементыФормы.ТабПоле.СоздатьКолонки();

Замена необходимых символов в строке на указанные

Данная функция позволяет найти в исходной строке значение и заменить на другое значение.При разработки конфигураций, часто требуется заменять какие либо символы в строке, по крайне мере я ей часто пользовался для упрощения работы. С данной задачей великолепно справляется функция СтрЗаменить.СинтаксисСтрЗаменить

Проверка на пустоту тип Дата

Если ПроверяемаяДата = Дата(1, 1, 1) Тогда Сообщить(«Дата пустая»); КонецЕсли; Вместо “Дата(1, 1, 1)” можно использовать следующие варианты: ‘00010101’ Дата(«00010101″) ‘00010101000000’ ‘0001-01-01′ Так же, можно использовать ЗначениеЗаполнено; Если НЕ ЗначениеЗаполнено(Объект.ПеременнаяДата) тогда     сообщить(«Строка пустая»); КонецЕсли;   В запросах 1. Дата

Склонение фамилии, имени и отчества по падежам в 1С 8.1

Версия склонения ФИО для 1C 8.2 Синтаксис Просклонять (<ФИО>, <Падеж>, <Пол>) Параметры <ФИО> – обязательный – строка содержащая фамилию, имя и отчество в именительном падеже единственного числа. Допустимые сочетания фамилии, имени и отчества: ФИО, ИОФ, ИО, ИФ, ФИ, Ф, И, О. Для

Проверка строки на пустоту

1 способ используя универсальную функцию ЗначениеЗаполнено(<исходная строка>) // если строка пустая или содержит только пробелы // тогда условие выполнится Строка = » «; Если НЕ ЗначениеЗаполнено(Строка) тогда сообщить("Строка пустая"); КонецЕсли; 2 способ сравнив значение с пустым значением (”“) // условие

Функции для работы с регистром строки

НРег – преобразование символов строки в нижний регистр Синтаксис НРег (<Исходная строка>) Параметры <Исходная строка> – исходная строка. Описание Преобразует все символы строки в нижний регистр. Доступность (для версии 8.2) Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение. Пример //

Завершение работы пользователей

Нужно создать ярлыки (средствами windows) с командами или запускать через cmd: Для Файлового варианта Отключение пользователей: «C:\Program Files\1cv81\bin\1cv8.exe» ENTERPRISE /F <путь к базе> /N <имя> /P <пароль> /WA- /AU- /DisableStartupMessages /C ЗавершитьРаботуПользователей При этом произойдет запуск программы под админскими правами